杭电 HDU 1021 Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 41156    Accepted Submission(s): 19705


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 

Author
Leojay
 
 
我说这个题目想当有意思,首先上去就做,压根就没考虑数组溢出n到几百就不行了;最关键的一点是题目要求一种是与否的判断,那就好好找找规律,结果直接让他输出100个f【n】看是否能被3整除的数据是如何分布的,立刻就遇到了惊喜!请看:
#include<iostream>
using namespace std;

int main()
{
	int n;
	int *ls=new int [10000000];
	ls[0]=7;ls[1]=11;
	for(int i=2;i<100;i++)
	{
		ls[i]=ls[i-1]+ls[i-2];
		/*if(ls[i]%3==0)
	      cout<<"yes"<<" ";
		  else
		  cout<<"no"<<" ";*/
	}
while(cin>>n)
{

	
printf((n-1)%4==1?"yes\n":"no\n");
}
//printf(ls[n]%3?"no":"yes");
return 0;
}

结果AC代码能猜出几行么!!呵呵呵

#include<iostream>
using namespace std;

int main()
{
	int n;
	while(cin>>n)
	{
		printf((n-1)%4==1?"yes\n":"no\n");
	}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值