杭电 HDU 1033 Edge

Edge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2251    Accepted Submission(s): 1439


Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
 

Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.
 

Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.


 

Sample Input
  
  
V AVV
 

Sample Output
  
  
300 420 moveto 310 420 lineto 310 430 lineto stroke showpage 300 420 moveto 310 420 lineto 310 410 lineto 320 410 lineto 320 420 lineto stroke showpage
 

Source

 

今天晚上哥哥也是醉了,熬夜到这时候,不负所望,AC之,其实这个题看起来高大上的样子,读了三遍才懂它什么意思。不过我的解法确实很麻烦,但虽然写的那么复杂,唉 起码锻炼思维逻辑能力了;

分析:题目首先给出了两个点的坐标,隐含给出了最后一次画线线头的方向,接下来对str数组中的每一步模拟,如果从坐标相等,判断相邻两次横坐标大小,用以判断线头方向,从而决定是横纵坐标哪个加一。

提交上去后,是各位小伙子们简直理解不了的亢奋哦!不知道最近疯狂的爱上acm了,以至于天天都不愿意去上课了丫的。接下来的代码看起来很苯蛋的样子,自己都服了。妈的。

上代码:

#include<iostream>
using namespace std;
#include<string>
int main()
{
	int t[200],k[200];
	string str1;
	string str[]={"moveto","lineto"};
	while(cin>>str1)
	{
		 t[0]=300;k[0]=420;
		 t[1]=310;k[1]=420;
		 int flag=0;
		cout<<t[0]<<" "<<k[0]<<" "<<str[0]<<endl
			<<t[1]<<" "<<k[1]<<" "<<str[1]<<endl;
		
		str1="  "+str1;
		for(int i=2;i<str1.size();i++)
		{
			switch(str1[i])
			{
			case 'V':
				{
					if(flag)
					{
						if((t[i-1]==t[i-2]))
						{
							if((k[i-1]>k[i-2]))
							{
								k[i]=k[i-1];
							   t[i]=t[i-1]-10;
							}
							else
							{
								k[i]=k[i-1];
								t[i]=t[i-1]+10;
							}

						}
						else
						{
							if(t[i-1]>t[i-2])
							{
							   t[i]=t[i-1];
							   k[i]=k[i-1]+10;
							}
							else
							{
								t[i]=t[i-1];
								k[i]=k[i-1]-10;
							}
						}
						cout<<t[i]<<" "<<k[i]<<" "<<str[1]<<endl;
					}
					else
					{
						cout<<t[1]<<" "<<k[1]+10<<" "<<str[1]<<endl;
						k[2]=k[1]+10;
						t[2]=t[1];
					}
					  flag=1;
					  break;
				}
			case'A':
				{
					if(flag)
					{
						if(t[i-1]==t[i-2])
						{
							if(k[i-1]<k[i-2])
							{
							  t[i]=t[i-1]-10;
							  k[i]=k[i-1];
							}
							else 
							{
								t[i]=t[i-1]+10;
								k[i]=k[i-1];
							}
						}
						else
						{
							if(t[i-1]<t[i-2])
							{
							  k[i]=k[i-1]+10;
							  t[i]=t[i-1];
							}
							else
							{
								k[i]=k[i-1]-10;
								t[i]=t[i-1];
							}
						}
						cout<<t[i]<<" "<<k[i]<<" "<<str[1]<<endl;
						}
					 else
					 {
						 cout<<t[1]<<" "<<k[1]-10<<" "<<str[1]<<endl;
						 k[2]=k[1]-10;
						 t[2]=t[1];
					 }
					  flag=1;
					  break;
				}
			default:
				break;
			}
			
			
		}
		cout<<"stroke"<<endl
				<<"showpage"<<endl;
	}
	return 0;

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值