杭电 HDU ACM 1859 最小长方形

最小长方形

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8100    Accepted Submission(s): 4394


Problem Description
给定一系列2维平面点的坐标(x, y),其中x和y均为整数,要求用一个最小的长方形框将所有点框在内。长方形框的边分别平行于x和y坐标轴,点落在边上也算是被框在内。
 

Input
测试输入包含若干测试用例,每个测试用例由一系列坐标组成,每对坐标占一行,其中|x|和|y|小于 231;一对0 坐标标志着一个测试用例的结束。注意(0, 0)不作为任何一个测试用例里面的点。一个没有点的测试用例标志着整个输入的结束。
 

Output
对每个测试用例,在1行内输出2对整数,其间用一个空格隔开。第1对整数是长方形框左下角的坐标,第2对整数是长方形框右上角的坐标。
 

Sample Input
  
  
12 56 23 56 13 10 0 0 12 34 0 0 0 0
 

Sample Output
  
  
12 10 23 56 12 34 12 34
 

Source
大半夜的这个题可气人了 ,以前循环喜欢这样写 while(cin>>x>>y,x+y)可这次非得这样写while((cin>>x>>y)&&(x||y));妈的蛋  浪费太多时间发现她,就是不知道为啥。
以前也没错过啊! 
 

AC一:

#include<iostream>
#include<algorithm>
using namespace std;
int ls[100000], gq[100000];
int main()
{
int i=0;
while((cin>>ls[i]>>gq[i])&&(ls[i]||gq[i]))
{
	 i++;
	while((cin>>ls[i]>>gq[i])&&(ls[i]||gq[i]))
	i++;
    sort(ls,ls+i);
	 sort(gq,gq+i);
	 cout<<ls[0]<<" "<<gq[0]<<" "<<ls[i-1]<<" "<<gq[i-1]<<endl;
	 i=0;

}
return 0;
}

AC二:

#include<iostream>
#include<algorithm>
using namespace std;
struct co
{
	int x;
	int y;
}per[10000];
bool cmp1(co a,co b)
{
	return a.x<b.x;
}
bool cmp2(co a,co b)
{
	return a.y<b.y;
}

int main()
{
	int x,y,i=0;
while(1)
{
	i=0;
while((cin>>per[i].x>>per[i].y)&&(per[i].x||per[i].y))
	{i++;}
     if(!i)
	 {
	
		 break;
	 }
	sort(per,per+i,cmp1);
	int k=per[0].x;int m=per[i-1].x;
	sort(per,per+i,cmp2);
	int l=per[0].y;int u=per[i-1].y;
	cout<<k<<" "<<l<<" "<<m<<" "<<u<<endl;
}
return 0;
}




 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值