杭电 HDU ACM 1159 Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26493    Accepted Submission(s): 11771


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 
 
表示好几天 没有a过题目了 ,原因好多,平时课程多死,省赛训练也经常跑西区,做的题目也不再是水题了,主要学习过程挺费时间 ,我相信只要把某个算法学会了,然后
做的类似的题目就不会浪费时间了。 今天五一 也算有了一点点 属于自己的时间,(其实五一还是有好多事情要干)。
参考学习了网上这篇博文,和《算法导论》叙述得差不多,
代码敲的少啊 ,连scanf()语法也卡了好大会儿。不过 以后知道了……
 
其实我感觉 string处理字符串 也挺方便。
#include<iostream >
#include<stdio.h>
#include<cstring>
const int M=500;
using namespace std;
int main()
{
    char cnt[M],dic[M];
    int c[M][M],k,m;
    while(scanf("%s%s",cnt+1,dic+1)!=EOF)
    {
        int  lencnt=strlen(cnt+1);
        int lendic=strlen(dic+1);
        for(int i=1; i<=lencnt; i++)
            c[i][0]=0;
        for(int j=0; j<=lendic; j++)
            c[0][j]=0;
        for( k=1; k<=lencnt; k++)
            for( m=1; m<=lendic; m++)
            {
                if(cnt[k]==dic[m])
                {
                    c[k][m]=c[k-1][m-1]+1;
                }
                else
                {
                    c[k][m]=max(c[k-1][m],c[k][m-1]);
                }
            }
        cout<<c[lencnt][lendic]<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值