HDU 1016 Prime Ring Problem (搜索)

31 篇文章 0 订阅

Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

题意就算给一个n,从1到n组成如图的一个圆环,再按顺序逆序输出该圆环的数据

要求就算相邻两个数相加是素数,最后一个数跟第一个数相加也要求是素数

#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
int n, b[30], a[30], vis[30];
int isprime(int k){
	for (int i = 2; i <= sqrt(k); i++)
		if (k%i == 0)return 0;
	return 1;
}
void dfs(int d){
	if (d == n&&isprime(b[1] + b[d])){//首位之和为素数
		for (int i = 1; i < n; i++)
			cout << b[i] << " ";
		cout << b[n] << endl;
	}
	else {
		for (int i = 2; i <= n; i++)
			if (vis[i] == 0 && isprime(b[d] + a[i]))
                            vis[i] = 1, b[d + 1] = a[i], dfs(d + 1), vis[i] = 0;
	}//判断此时b[d]+a[i]是否为素数,若为素数,将a[i]加入b数组
}
int main(){
	int flag = 0, k = 1;
	while (cin >> n){
		for (int i = 1; i <= n; i++)
			a[i] = i;
		cout << "Case " << k << ":" << endl;
		memset(vis, 0, sizeof(vis));
		b[1] = 1;
		dfs(1);
		k++;
		cout << endl;
	}
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值