ACM-数论之 Fibonacci Again——hdu1021

这道题,虽然是个水题,但是没有一个数学公式,

难死了= =!,我暴力了很多遍还是没有成功,

我知道不能用暴力破解,但实在想不出来有什么方法,

没办法,求助咯,最终才知道有这么个余数公式:

(a+b)%3 = (a%3+b%3)%3

有了这个公式,那真是手到擒来了!

这题也体现出ACM与数学那不可分割的关系啊~


Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32807    Accepted Submission(s): 15874


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no





#include <iostream>
using namespace std;
int fib[1000001];		
int main()
{
	
	int i,n;

	fib[0]=7,fib[1]=11;
	for(i=2;i<1000001;i++)
		fib[i]=(fib[i-1]%3+fib[i-2]%3)%3;	

	while(cin>>n)
	{
		
		if(fib[n]==0)
			cout<<"yes"<<endl;
		else
			cout<<"no"<<endl;
		
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值