BZOJ 1635: [Usaco2007 Jan]Tallest Cow 最高的牛

1635: [Usaco2007 Jan]Tallest Cow 最高的牛

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 641   Solved: 390
[ Submit][ Status][ Discuss]

Description

FJ's N (1 <= N <= 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 <= H <= 1,000,000) of the tallest cow along with the index I of that cow. FJ has made a list of R (0 <= R <= 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17. For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

有n(1 <= n <= 10000)头牛从1到n线性排列,每头牛的高度为h[i](1 <= i <= n),现在告诉你这里面的牛的最大高度为maxH,而且有r组关系,每组关系输入两个数字,假设为a和b,表示第a头牛能看到第b头牛,能看到的条件是a, b之间的其它牛的高度都严格小于min(h[a], h[b]),而h[b] >= h[a]

Input

* Line 1: Four space-separated integers: N, I, H and R

 * Lines 2..R+1: Two distinct space-separated integers A and B (1 <= A, B <= N), indicating that cow A can see cow B.

Output

* Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8


INPUT DETAILS:

There are 9 cows, and the 3rd is the tallest with height 5.

Sample Output

5
4
5
3
4
4
5
5
5

HINT

Source


题解:说实话,很暴力,只是个思想,差分思想,但程序很暴力的。。。


代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{int x,y;}a[10001];
int f[10001];
int N,I,H,R;
int x,y,num;
bool cmp(node x,node y)
{
	if(x.x<y.x)return true;
	if(x.x==y.x&&x.y<y.y)return true;
	return false;
}
int main()
{
	scanf("%d%d%d%d",&N,&I,&H,&R);
	for(int i=1;i<=R;i++)
	{
		scanf("%d%d",&x,&y);
		if(y<x)swap(x,y);           //将x,y确定为x<y,方便之后的计算 
		a[i].x=x;a[i].y=y;
	}
	sort(a+1,a+R+1,cmp);           //按x的从小到大来排,如果相等就按y
	                               //的从小到大来排,同样方便之后的计算。。。cmp在上面 
	for(int i=1;i<=R;i++)
	{
		if(a[i].x==a[i-1].x&&a[i].y==a[i-1].y)continue;
		f[a[i].x+1]--;
		f[a[i].y]++;
	}                              //统计 
	for(int i=1;i<=N;i++)
	{
		num+=f[i];
		printf("%d\n",num+H);      //输出 
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值