POJ-2965

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24648 Accepted: 9503 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion
//注意一点的是取反偶数次相当于棋子没有变化,取反奇数次相当于变一次
//本题的算法从根部进行枚举,每次枚举此情况后继续往后搜索,判断是否符合情况,如何符合返回,不符合将状态状态还原
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int map[5][5];
int x[20]; // 临时路径
int y[20];

int ansX[20]; // 最终路径
int ansY[20];
int ans = 18;

void build()
{
	char c;
	memset(map, 0, sizeof(map));
	for (int i = 0; i < 4; i++)
	{
		for (int j = 0; j < 4; j++)
		{
			cin >> c;
			if (c == '-')
			{
				map[i][j] = 1;    //open
			}
			else
			{
				map[i][j] = 0;
			}
		}
	}
}

void flip(int s)//使此位置的行列进行取反
{
	int x1 = s / 4; // 行
	int y1 = s % 4; // 列

	for (int i = 0; i < 4; i++)
	{
		map[i][y1] = !map[i][y1];
		map[x1][i] = !map[x1][i];
	}
	map[x1][y1] = !map[x1][y1];
}

bool complete() // 判断是否达到目标
{
	for (int i = 0; i < 4; i++)
	{
		for (int j = 0; j < 4; j++)
			if (map[i][j] == 0)
			{
				return false;//只要有0就返回false
			}
	}
	return true;//只有全部为1时才返回true
}

void dfs(int s, int b) // 遍历到第 s 个, 翻转了 0个
{
	if (complete())//全部为1时返回
	{
		if (ans > b)
		{
			ans = b;
			for (int i = 1; i <= ans; i++)
			{
				ansX[i] = x[i];
				ansY[i] = y[i];
			}
		}
		return;
	}

	if (s >= 16)//遍历到全部取反时返回
	{
		return;
	}

	dfs(s + 1, b); //不管第 s 个,直接往下找

	flip(s); //翻转第 s 个了再往下找
	x[b + 1] = s / 4 + 1; //临时记录路径【注意】
	y[b + 1] = s % 4 + 1;

	dfs(s + 1, b + 1); //翻转第 s 个了再找下一个=>进行了一次判断是否全为1

	flip(s); //使用dfs,要考虑到树根时如果还没成功,要回溯;回溯时要把棋子再翻回来,再搜。
}

int main()
{
	build();
	dfs(0, 0);
	printf("%d\n", ans);
	for (int i = 1; i <= ans; i++)
	{
		printf("%d %d\n", ansX[i], ansY[i]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值