Prime Ring Problem 素环问题 acm入门 day1---bfs_dfs第二题

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
在这里插入图片描述

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

意思是,输入一个数字n,然后将1到n连成一个环,这个环的条件是:
相邻两个数字之和为素数
然后输出每一种方案,按字典序输出。

不用被字典序难到,因为dfs,只要是按数字从小到大进行深搜,输出的答案自然就是字典序了。

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

下面上代码

#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

int vis[21];
int temp[21];
int n;
//判断是否为素数,这个不用多说了叭
bool isPrime(int x)
{
	for(int i=2;i<=sqrt(x);i++)
	if(x%i==0) return false;
	return true;
}

void dfs(int x,int c)
{
	if(c>=n)
	{
		//注意,这里还要判断下首尾是否和也是素数
		if(isPrime(temp[0]+temp[n-1]))
		{
			for(int i=0;i<n;i++)
			{
					printf("%d",temp[i]);
					if(i!=n-1) printf(" ");
			}
					
			printf("\n");
		}
		return ;
	}for(int i=2;i<=n;i++)
	{
		if(!vis[i]&&isPrime(x+i))
		{
			vis[i]=1;
			temp[c]=i;	
			dfs(i,c+1);
			vis[i]=0;
		//回溯,将标记去掉
		
		}
	}
	
}


int main()
{
	int idx=1;
	while(scanf("%d",&n)!=EOF)
	{
		memset(vis,0,sizeof(vis));
		memset(temp,0,sizeof(temp));
		vis[1]=1;
		printf("Case %d:\n",idx++);
		temp[0]=1;
		dfs(1,1);	
		printf("\n");
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值