【ACM- OJ】《prime circle》C++

题目描述

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

输入

n (0 < n < 20).
(multi test case)

输出

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

样例输入

6
8

样例输出

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

AC代码

//
//  main.cpp
//  prime circle
//
//  Created by HISS on 2020/10/24.
//  Copyright © 2020 HISS. All rights reserved.
//

#include <iostream>
using namespace std;
 
int num[21], mark[21], n;
int prime_num[12] = {2,3,5,7,11,13,17,19,23,29,31,37};
 
//判断是否是质数,是返回1,不是返回0
int is_prime(int a)
{
    int i;
    for(i = 0; i < 12;i++)
        if(a == prime_num[i])
            return 1;
    return 0;
}

//num数组中是circle的顺序
void print_num()
{
    int i;
    for(i = 1; i < n; i ++)
        cout << num[i] << " ";
    cout << num[n];
}

//pre是栈顶元素,post是栈外元素,flag 是将要进 circle 的数量
int dfs(int pre, int post, int flag)
{
    //如果不符合,直接返回
    int i;
    //前 + 后若不是素数,则返回 0
    if(!is_prime(pre + post))
        return 0;
    //此时 pre + post 是素数
    num[flag] = post;
    //成功,打印,返回
    if(flag == n && is_prime(post + 1))
    {
        print_num();
        cout << endl;
        return 1;
    }
    //使用过了这个数字就标记为0
    mark[post] = 0;
    //对没使用的第一个进行深搜(不返回 0 )然后 break
    for(i = 2; i <= n; i ++)
        if(mark[i] != 0 && dfs(post, i, flag + 1))
            break;
    //标记位恢复原状
    mark[post] = 1;
    //深搜失败(要出栈了)
    return 0;
}
 
int main()
{
    int count, i;
    count = 1;
    while(cin >> n)
    {
        //mark 是标记,如果没使用就是它本身,使用了就是0
        for(i = 1; i <= n; i ++)
            mark[i] = i;
        //第一个等于1
        num[1] = 1;
        cout << "Case " << count << ":" << endl;
        count ++;
        if(n == 1)
            cout << 1 << endl;
        //从第二个到第 n 个,每一个都深搜一次
        for(i = 2; i <= n; i ++)
            dfs(1, i, 2);
        cout << endl;
    }
    return 0;
}

  • 5
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值