PAT甲1010 最大进制不一定是36

1010. Radix (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is "yes", if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N1 and N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:
N1 N2 tag radix
Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set {0-9, a-z} where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number "radix" is the radix of N1 if "tag" is 1, or of N2 if "tag" is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print "Impossible". If the solution is not unique, output the smallest possible radix.

Sample Input 1:
6 110 1 10
Sample Output 1:
2
Sample Input 2:
1 ab 1 2
Sample Output 2:
Impossible

这题好坑啊,最大进制不一定是36,可能是10000进制(然而大于36进制就不是很有意义了)
所以,这题会超 long long,还要用到二分法,下面是java版AC代码

注意:由于编码保存原因,会报编译错误,要去掉下面的中文注释


import java.math.BigInteger;
import java.util.Scanner;

public class Main {

	static BigInteger trans(String a, BigInteger radix){
		BigInteger ans;
		int t;
		ans = BigInteger.ZERO;
		for(int i = 0; i < a.length(); i++){
			if(a.charAt(i) <= '9')
				t = a.charAt(i) - '0';
			else
				t = a.charAt(i) - 'a' + 10;
			ans = ans.multiply(radix);
			ans = ans.add(BigInteger.valueOf(t));
		}
		return ans;
	}
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String a, b,c;
		BigInteger u, m, mid, low, high ;
		int tag, radix;
		BigInteger TWO = new BigInteger("2");
		a = sc.next();
		b = sc.next();
		tag = sc.nextInt();
		radix = sc.nextInt();
		if(tag == 1){
			u = trans(a, BigInteger.valueOf(radix));
			c = b;
		}
		else{
			u = trans(b, BigInteger.valueOf(radix));
			c = a;
		}
		
		/*只有当另一个数字符串长度为1是结果才可能出现多个*/
		if(c.length() == 1){
			int temp;
			if(c.charAt(0) <= '9')
				temp = c.charAt(0) - '0';
			else
				temp = c.charAt(0) - 'a' + 10;
			if(u.equals(BigInteger.valueOf(temp))){
				System.out.println(temp + 1);
				
			}
			else {
				System.out.println("Impossible");
			}
			return;
		}
		
		/*二分法,先找最大进制和最小进制*/
		int min = -1;
		for(int i = 0; i < c.length(); i++) {
			if(c.charAt(i) > min)
				min = c.charAt(i);
		}
		if(min <= '9')
			min = min - '0';
		else
			min = min - 'a' + 10;
		/*最大进制为low和u二者的较大者*/
		low = BigInteger.valueOf(min + 1);        
		if(u.compareTo(low) > 0) {
			high = u;
		}
		else {
			high = low;
		}
		while(low.compareTo(high) <= 0) {
			m = low.add(high).divide(TWO);
			mid = trans(c, m);
			if(mid.compareTo(u) == 0) {
				System.out.println(m);
				return;
			}
			else if(mid.compareTo(u) < 0) 
				low = m.add(BigInteger.ONE);
			else
				high = m.subtract(BigInteger.ONE);
		}
		System.out.println("Impossible");
		sc.close();
	}

}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值