Palindrome(POJ 1159)

C - Palindrome
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description: 

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

最长公共子序列
code:
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define maxn 5010
char s1[maxn],s2[maxn];
int d[2][maxn];
int main(){
    int n;
    cin>>n>>s1;
    for(int i=0;i<n;i++) s2[i]=s1[n-1-i];
    memset(d,0,sizeof(d));
    for(int a=1;a<=n;a++){
        for(int b=1;b<=n;b++){
            if(s1[a-1]==s2[b-1]) d[a%2][b]=d[(a-1)%2][b-1]+1;
            else d[a%2][b]=max(d[(a-1)%2][b],d[a%2][b-1]);
        }
    }
    cout<<n-d[n%2][n]<<endl;
    return 0;
}
关于此题,有一篇很好的题解:http://blog.csdn.net/lyy289065406/article/details/6648163

设原序列S的逆序列为S' ,则这道题目的关键在于,

最少需要补充的字母数 = 原序列S的长度 —  S和S'的最长公共子串长度
这个公式我不证明,不难证
剩下的就小意思了,最基础的LCS题。

注意本题空间开销非常大,需要适当的处理手法

 

先看看几种不同的申请空间方法的区别:

1. 静态数组 开销大小为5001*5001的int是铁定超的.

据说用short int的话不会MLE,有兴趣的同学可以试试

2. 动态数组 单纯的申请动态数组是不能解决这个问题的,动态数组只能增加空间利用率,

            但是本题最恶劣的数组大小还是5001*5001,动态数组是不能改变这个事实的

3. 滚动数组 这里重点讲一下滚动数组在这个题目中的应用.自己目前理解的应用滚动数组的目的就是减少空间开销.首先可以在纸上简单模拟一下DP的转移过程.确定好最少行数或者列数之后,重点就是在如何进行"滚动"以及如何用表达式控制这个滚动.

对于本题,我用的是行数以0--1--0—1的滚动方式滚动表达式为i%2和(i-1)%2 ,没错,就是强大的求余滚动O(∩_∩)O 

由于应用了滚动数组,那么空间开销就能够从5001*5001压缩到 2*5001  !!!

哈哈,傻眼了吧\(^o^)/~

而且本题我为了稍微提高一点空间利用率,使用了 动态二维滚动数组,就是东邪(动态)西毒(滚动)的混合体O(∩_∩)O,这样做的目的,只是对测试数据库的数据抱有一点点希望:我相信它们不全都是5000的长度,所以我想能尽可能再节省一点列数….不过时间就惨不忍睹咯,1157ms….不过空间开销却由MLE跌落到谷底的280K\(^o^)/~



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值