Unidirectional TSP(UVA 116)

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1

19

题解:很简单的动态规划问题。

由于本题要求输出字典序最少的序列,所有代码应该从矩阵末端列元素(n-1)遍历到第一列元素。

状态转移方程为:

d[r][c]=min(d[(r-1+row)%row][c+1],d[r][c+1],d[(r+1)%row][c+1]);

由于本题要求输出最少花费的路径,所以应该建立一个数组来记录在某位置取到最优时的下一步行位置。

代码:c++

// Memory 0Kb ; Times 222ms

#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
int board[11][110];
int pos[11][110];
int row,col;
void deal(int r,int c){
    int p[2];
    int mSum;
    int ans;
    mSum=board[r][c+1];
    ans=r;
    p[0]=(r-1+row)%row;
    p[1]=(r+1)%row;
    for(int a=0;a<2;a++){
        if(mSum>board[p[a]][c+1]){
            mSum=board[p[a]][c+1];
            ans=p[a];
        }else if(mSum==board[p[a]][c+1]){
            if(ans>p[a]) ans=p[a];
        }
    }
    pos[r][c]=ans;
    board[r][c]+=mSum;
}
int main(){
    while(cin>>row>>col){
        for(int a=0;a<row;a++)
            for(int b=0;b<col;b++)
                cin>>board[a][b];
        memset(pos,0,sizeof(pos));
        for(int c=col-2;c>=0;c--){
            for(int r=0;r<row;r++){
                deal(r,c);
            }
        }
        int mSum;
        int ans;
        mSum=board[0][0];
        ans=0;
        for(int a=1;a<row;a++){
            if(mSum>board[a][0]){
                mSum=board[a][0];
                ans=a;
            }
        }
        cout<<ans+1;
        for(int a=0;a<col-1;a++){
            cout<<" "<<pos[ans][a]+1;
            ans=pos[ans][a];
        }
        cout<<endl;
        cout<<mSum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值