hdoj3832

Earth Hour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)

Problem Description
Earth Hour is an annual international event created by the WWF (World Wide Fund for Nature/World Wildlife Fund), held on the last Saturday of March, that asks households and businesses to turn off their non-essential lights and electrical appliances for one hour to raise awareness towards the need to take action on climate change. 
To respond to the event of this year, the manager of Hunan University campus decides to turn off some street lights at night. Each street light can be viewed as a point in a plane, which casts flash in a circular area with certain radius.
What's more, if two illuminated circles share one intersection or a point, they can be regarded as connected.
Now the manager wants to turn off as many lights as possible, guaranteeing that the illuminated area of the library, the study room and the dormitory are still connected(directly or indirectly). So, at least the lights in these three places will not be turned off.
 

Input
The first line contains a single integer T, which tells you there are T cases followed.
In each case:
The first line is an integer N( 3<=N<=200 ), means there are N street lights at total.
Then there are N lines: each line contain 3 integers, X,Y,R,( 1<=X,Y,R<=1000 ), means the light in position(X,Y) can illuminate a circle area with the radius of R. Note that the 1st of the N lines is corresponding to the library, the 2nd line is corresponding to the study room, and the 3rd line is corresponding to the dorm.
 

Output
One case per line, output the maximal number of lights that can be turned off.
Note that if none of the lights is turned off and the three places are still not connected. Just output -1.
 

Sample Input
  
  
3 5 1 1 1 1 4 1 4 1 1 2 2 1 3 3 1 7 1 1 1 4 1 1 2 4 1 1 3 1 3 1 1 3 3 1 4 3 1 6 1 1 1 5 1 1 5 5 1 3 1 2 5 3 2 3 3 1
 

Sample Output
  
  
-1 2 1
 

Source
 

Recommend
xubiao
 
#include<stdio.h>

#define size 202
#define inf 100000000

int t;

int n;

int min;
int dir;

struct point{
    int x;
    int y;
    int r;
}point[size];

int map[size][size];

int dist[3][size];

int visit[size];

void dijkstra(void) {
    for (int k = 0; k < 3; k++) {
        for (int i = 0; i < n; i++) {
            dist[k][i] = map[k][i];
            visit[i] = 0;
        }
        dist[k][k] = 0;
        visit[k] = 1;
        for (int i = 0; i < n; i++) {
            min = inf;
            for (int j = 0; j < n; j++)
                if (!visit[j] && dist[k][j] < min) {
                    min = dist[k][j];
                    dir = j;
                }
            if (min == inf)
                break;
            visit[dir] = 1;
            for (int j = 0; j < n; j++)
                if (!visit[j] && dist[k][j] > dist[k][dir] + map[dir][j])
                    dist[k][j] = dist[k][dir] + map[dir][j];
        }
    }
}

int main(void)
{
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++)
            scanf("%d%d%d",&point[i].x,&point[i].y,&point[i].r);
        for(int i=0;i<n;i++){
            for(int j=0;j<n;j++){
                if((point[i].x-point[j].x)*(point[i].x-point[j].x)
                        +(point[i].y-point[j].y)*(point[i].y-point[j].y)
                        <=(point[i].r+point[j].r)*(point[i].r+point[j].r)){
                    map[i][j]=1;
                    map[j][i]=1;
                }
                else{
                    map[i][j]=inf;
                    map[j][i]=inf;
                }
            }
        }
        dijkstra();
        min=inf;
        for(int i=0;i<n;i++){
            if(dist[0][i]+dist[1][i]+dist[2][i]<min)
                min=dist[0][i]+dist[1][i]+dist[2][i];
        }
        
        if(min==inf)
            printf("-1\n");
        else printf("%d\n",n-min-1);
        
           
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值