hdoj1042

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33698    Accepted Submission(s): 9380


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)
#include<stdio.h>
#include<string.h>
int number[100001];

int main(void) {
    int n;
    while (scanf("%d", &n) != EOF) {
        memset(number, 0, sizeof (number));
        number[0] = 1;
        int digit=0;//最高位
        for (int i = 2; i <= n; i++) {
            int c = 0;
            for (int j = 0; j <=digit; j++) {
                int s = number[j] * i + c;
                number[j] = s % 10;
                c = s / 10;
            }
            while(c){//进位
                number[++digit]=c%10;
                c/=10;                
            }
        } 
        for(int i=digit;i>=0;i--)
            printf("%d",number[i]);
        printf("\n");        
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值