poj3370

Halloween treats

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space separated integers a1 , ... , an(1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source

题目要求对于多解的情形只用输出一组解,如果无解,就输出“no sweets”但根据抽屉原理,可以得出没有无解的情况。思路分析:运用鸽巢原理解题。首先简单说一下鸽巢原理,就是有n+1个球,放在n个盒子中,那么至少有一个盒子有两个或更多的球。鸽巢原理理解起来并不难,但关键是将鸽巢原理运用到题目中去。比如本题,我们可以构造一个序列,有以下两种可能
构造序列si,使得
s1=a1
s2=a1+a2
s3=a1+a2+a3
...
sn=a1+a2…+an
这样,有两种可能:
(1)若其中有一项si是c的倍数,则即找到解;
(2)否则,si=ri (mod c),取值只可能在[1,c-1]这c-1个数,然而有n个数,且c<=n,则必然存在两个数si和sj对c取模相等。首先肯定了原问题的答案肯定存在。若sj>si,则序列ai+1,...aj即为原问题的一种方案。

代码如下:
#include<stdio.h>
#include<string.h>

int main(void) {
    int left[100001];
    int neighboor[100001];
    int c; //孩子数量
    int n; //邻居数量
    int remind; //所有糖对c取模的余数
    int start; //子序列的开始
    int end; //子序列的结束
    while (scanf("%d%d", &c, &n), c + n) {
        memset(left, 0, sizeof (left)); //数组初始化为0
        remind = 0;
        for (int i = 1; i <= n; i++)
            scanf("%d", &neighboor[i]);
        for (int i = 1; i <= n; i++) {
            remind = (remind + neighboor[i]) % c;
            if (remind == 0) {//如果renmind=0,说明正好除尽,每个孩子分得糖果数量相等
                start = 1;
                end = i;
                break;
            }
            if (left[remind]) {//如果left[remind]不等于0,则从上一个余数为remind的邻居到这个邻居加了n个c
                start = left[remind] + 1;
                end = i;
                break;
            } else
                left[remind] = i;
        }
        for (int i = start; i < end; i++)//输出结果
            printf("%d ", i);
        printf("%d\n", end);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值