poj3112

Pie

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source

二分法。代码如下:

#include<iostream>
#include<iomanip>
using namespace std;
const double pi = 3.14159265358979; //pi的值
const double eps = 1e-6; //控制精度

int main(void) {
    int c;
    cin >> c; //测试用例数
    while (c--) {
        int n, f; //pie的数量,朋友的数量
        double pie[10001];
        cin >> n >> f;
        f++; //自己也要分得pie
        double max = 0; //最大的pie
        for (int i = 0; i < n; i++) {
            cin >> pie[i];
            pie[i] *= pie[i];
            if (pie[i] > max)
                max = pie[i];
        }//找出最大的pie
        double up = max; //上界,每人都得到整个pie,而且那个pie为所有pie中最大的
        double down = 0; //下界,每人都分不到pie
        double mid; //中值
        while (up - down > eps) {//二分求解,当精度符合时中止循环
            mid = (up + down) / 2;
            int tmp = 0; //按照当前分法可以分给多少人
            for (int i = 0; i < n; i++)
                tmp += (int) (pie[i] / mid);
            if (tmp < f)//如果能分得的人数少于总人数,说明上界过大,将上界优化为中值
                up = mid;
            else//否则下界过小,将下界优化为中值,注意等号一定要放在下界优化,否则精度会出错
                down = mid;
        }
        cout << fixed << setprecision(4) << mid * pi << endl; //输出结果
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值