poj3259

Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

spfa算法中,当出现负环的时候某个节点进出队列的次数一定大于或等于节点数。
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
int map[5500][5500];
int dist[5500];
int cnt[5500];
int inqueue[5500];

int spfa(int n) {
    queue<int> Q;
    while (!Q.empty())
        Q.pop();
    memset(inqueue, 0, sizeof (inqueue));
    memset(cnt, 0, sizeof (cnt));
    for (int i = 0; i < 5500; i++)
        dist[i] = 100000000;
    dist[1] = 0;
    inqueue[1] = 1;
    cnt[1]++;
    Q.push(1);
    while (!Q.empty()) {
        int tmp = Q.front();
        Q.pop();
        inqueue[tmp] = 0;
        for (int i = 1; i <= n; i++) {
            if (dist[tmp] + map[tmp][i] < dist[i]) {
                dist[i] = dist[tmp] + map[tmp][i];
                if (!inqueue[i]) {
                    cnt[i]++;
                    if (cnt[i] >= n)
                        return 1;
                    inqueue[i] = 1;
                    Q.push(i);
                }
            }
        }
    }
    return 0;
}

int main() {
    int test_cases;
    cin >> test_cases;
    while (test_cases--) {
        int n, m, w;
        cin >> n >> m >> w;
        for (int i = 0; i <= n; i++)
            for (int j = 0; j <= n; j++)
                map[i][j] = 100000000;
        for (int i = 0; i < m; i++) {
            int s, e, t;
            cin >> s >> e >> t;
            if (map[s][e] > t)
                map[s][e] = map[e][s] = t;
        }
        for (int i = 0; i < w; i++) {
            int s, e, t;
            cin >> s >> e >> t;
            map[s][e] = -t;
        }
        if (spfa(n))
            cout << "YES\n";
        else
            cout << "NO\n";
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值