Electric Fence

 描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20

题目大意是以(0, 0),(p, 0),(n, m)三个点围成的三角形内部有几个不在边界上的整数点。

皮克定理

用于计算点阵中顶点在格点上的多边形的面积;

公式表达为2S= 2a + b - 2.

S表示多边形的面积,a表示多边形内部的点数,b表示多边形边界上的点数。

S使用海伦公式S=sqrt(p(p-x)(p-y)(p-z)。x,y,z是边长,p是半周长。

#include <bits/stdc++.h>
using namespace std;
int gcd(int x, int y)
{
    if (x < y)
        return gcd(y, x);
    if (y == 0)
        return x;
    return gcd(y, x % y);
}
int main()
{
    int a, b, c;
    double x, y, z;
    cin >> a >> b >> c;
    x = sqrt(a * a + b * b);
    y = sqrt((a - c) * (a - c) + b * b);
    z = c;
    double p = ((double)x + y + z) / 2;
    double s = sqrt(p * (p - x) * (p - y) * (p - z));
    b = gcd(a, b) - 1 + gcd(abs(c - a), b) + c;
    cout << (int)((2 * s + 2 - b) / 2) << endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值