算法笔记6116ProblemE Shortest Distance

题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

在这里插入图片描述

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

代码展示

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int MAX = 100000;
int dist[MAX]; // dist数组用来存放从第一个点开始顺向与各个点的距离

int main()
{
    int n, m;
    int total = 0; // total用来记录整个环的长度
    int temp; // temp暂存每次输入的两点间的距离
    int begin, end;
    scanf("%d", &n);
    dist[1] = 0;
    for(int i = 1; i <= n; i++) {
        scanf("%d", &temp);
        total += temp;
        dist[i + 1] = dist[i] + temp;
    }

    scanf("%d", &m);
    while(m--) {
        scanf("%d%d", &begin, &end);
        temp = abs(dist[end] - dist[begin]);
        printf("%d\n", min(temp, total - temp)); // 只需比较顺向和逆向两个方向
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值