[sicily]1795. Table tennis

1795. Table tennis

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The 49th World Table Tennis Championships was held in Guangzhou from February 24th to March 2nd. It was a chance not to be missed for the table tennis enthusiast. TZD and other table tennis enthusiast in Sun Yat-sen University decided to watch the first day’s matches. That day when they got to the gymnasium, there was still an hour left. So they decided to walk around. They found that not far away there were some children playing games round a table. This game was played like this: you stand by the table on one side, and on the other side there is a machine to serve you the balls one by one. Then you hit the balls.

On the half of the table opposite to you, there are three circles of different size. From left to right, see figure 2, we call them big circle, middle circle and small circle. If you hit the ball onto the area inside the big circle, you will get one point. For the middle circle you will get two points. And for the small circle three points. But if you hit the ball right onto the boundary of circles, you will not get any points. If you get enough points, you will be given a small gift! TZD also wanted to have a try.

We assume that the circles are given by three integer (x- coordinate of the centre, y- coordinate of the centre, radius). From left to right the three circles are£¨30, 30, 20£©, £¨100, 30, 10£©, £¨170, 30, 5£©. And each hit is described by two integer (xpos, ypos), meaning that TZD hit the ball onto the position (xpos, ypos). Now please tell TZD how many points he got after N hits.

Input

The first line contains a positive integer TT is the number of test cases followed.

For each test case, there is a positive integer N (0≤N≤60) in the first line, the number of TZD’s hits. Next come N pairs of integer (xposypos), each pair in one line.(0≤xpos≤200, 0≤ypos≤100).

Output

For each test case, print the total points in one line.

Sample Input

3
2
30 31
100 32
1
30 50
3
30 30
99 30
170 30

Sample Output

3
0
6

简单几何题。题意为某人玩打乒乓球的游戏,有大中小三个洞,将乒乓球打进洞中就可得到相应的分,给出坐标,求某人的得分。直接计算欧氏距离判断,over。


#include <iostream>
using namespace std;

int main()
{ 
    int t;
    cin>>t;
    while(t--)
    {
        int n,x,y,sum=0;
        cin>>n;
        while(n--)
        {
            cin>>x>>y;
            if( ((30-x)*(30-x)+(30-y)*(30-y)) < 20*20 )
                sum = sum+1;
            else if( ((100-x)*(100-x)+(30-y)*(30-y)) < 10*10 )
                sum = sum+2;
            else if( ((170-x)*(170-x)+(30-y)*(30-y)) < 5*5 )
                sum = sum+3;
                 
        }
        cout<<sum<<endl;
    }
    //system("pause");
    return 0;   
}                                 



                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值