sicily-1795. Table tennis

1795. Table tennis


限制条件
时间限制: 1 秒, 内存限制: 32 兆


题目描述

The 49th World Table Tennis Championships was held in Guangzhou from February 24th to March 2nd. It was a chance not to be missed for the table tennis enthusiast. TZD and other table tennis enthusiast in Sun Yat-sen University decided to watch the first day’s matches. That day when they got to the gymnasium, there was still an hour left. So they decided to walk around. They found that not far away there were some children playing games round a table. This game was played like this: you stand by the table on one side, and on the other side there is a machine to serve you the balls one by one. Then you hit the balls.

On the half of the table opposite to you, there are three circles of different size. From left to right, see figure 2, we call them big circle, middle circle and small circle. If you hit the ball onto the area inside the big circle, you will get one point. For the middle circle you will get two points. And for the small circle three points. But if you hit the ball right onto the boundary of circles, you will not get any points. If you get enough points, you will be given a small gift! TZD also wanted to have a try.

We assume that the circles are given by three integer (x- coordinate of the centre, y- coordinate of the centre, radius). From left to right the three circles are£¨30, 30, 20£©, £¨100, 30, 10£©, £¨170, 30, 5£©. And each hit is described by two integer (xpos, ypos), meaning that TZD hit the ball onto the position (xpos, ypos). Now please tell TZD how many points he got after N hits.

输入格式

The first line contains a positive integer T. T is the number of test cases followed.
For each test case, there is a positive integer N (0≤N≤60) in the first line, the number of TZD’s hits. Next come N pairs of integer (xpos, ypos), each pair in one line.(0≤xpos≤200, 0≤ypos≤100).

输出格式

For each test case, print the total points in one line.

样例输入
3
2
30 31
100 32
1
30 50
3
30 30
99 30
170 30

样例输出
3
0
6


这道题意思是有大中小三个圈,坐标和半径分别为(30,30,20) (100,30,10)(170,30,5),球命中的得分分别是1,2,3。现在有T组测试数据,每组头N次,每次的坐标为xpos,ypos,求每组的得分。

这道题就是一道纯几何题,关键是判断在哪个圈内。


//1795. Table tennis
//2016.11.29

#include <iostream>
#include <cmath>

using namespace std;

int s(int xpos,int ypos) 
{
	int sum=0;
	if(((xpos-30)*(xpos-30)+(ypos-30)*(ypos-30))<400)
		sum+=1;
	if(((xpos-100)*(xpos-100)+(ypos-30)*(ypos-30))<100)
		sum+=2;
	if(((xpos-170)*(xpos-170)+(ypos-30)*(ypos-30))<25)
		sum+=3;
	return sum;
}

int main()
{
	int t,n,xpos,ypos;
	cin>>t;
	while(t--)
	{
		cin>>n;
		int sum=0;
		for(int i=0;i<n;i++)
		{
			cin>>xpos>>ypos;
			sum+=s(xpos,ypos);
		}
		cout<<sum<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值