[sicily]1200. Stick

1200. Stick

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 Anthony has collected a large amount of sticks for manufacturing chopsticks. In order to simplify his job, he wants to fetch two equal-length sticks for machining at a time. After checking it over, Anthony finds that it is always possible that only one stick is left at last, because of the odd number of sticks and some other unknown reasons. For example, Anthony may have three sticks with length 1, 2, and 1 respectively. He fetches the first and the third for machining, and leaves the second one at last. You task is to report the length of the last stick. 

Input

The input file will consist of several cases.   

Each case will be presented by an integer n (1<=n<=100, and n is odd) at first. Following that, n positive integers will be given, one in a line. These numbers indicate the length of the sticks collected by Anthony.   

The input is ended by n=0. 

Output

For each case, output an integer in a line, which is the length of the last stick. 

Sample Input

3
1
2
1
0

Sample Output

2


简单数字相等匹配问题。奇数个数字里面,只有一个是没有配对的,找出这个数来。测试样例数据比较弱,直接暴力循环查找可以,对每一个 sticks[i] 进行查找看有没相等匹配的存在,有则做好标记。代码如下:


#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
	int t;
	
	while(cin>>t && t>0)
	{
		int sticks[t];
		for(int i=0; i<t; i++)
		{
			cin>>sticks[i];
			for(int j=0; j<i; j++)
			{
				if(sticks[i] == sticks[j])
				{
					sticks[i] = 0;
					sticks[j] = 0;
					break;
				}
			}
		} 
		for(int i=0; i<t; i++)
		{
			if(sticks[i]>0)
				cout<<sticks[i]<<endl;
		}
	} 
    //system("pause");
    return 0;   
}                                                             


Submit
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值