sicily 1200. Stick

1200. Stick

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 Anthony has collected a large amount of sticks for manufacturing chopsticks. In order to simplify his job, he wants to fetch two equal-length sticks for machining at a time. After checking it over, Anthony finds that it is always possible that only one stick is left at last, because of the odd number of sticks and some other unknown reasons. For example, Anthony may have three sticks with length 1, 2, and 1 respectively. He fetches the first and the third for machining, and leaves the second one at last. You task is to report the length of the last stick. 

Input

The input file will consist of several cases.   

Each case will be presented by an integer n (1<=n<=100, and n is odd) at first. Following that, n positive integers will be given, one in a line. These numbers indicate the length of the sticks collected by Anthony.   

The input is ended by n=0. 

Output

For each case, output an integer in a line, which is the length of the last stick. 

Sample Input

31210

Sample Output

2

题目分析

水题
奇数根木棍,不同种类的有偶数个,有一种只有奇数个。
找到奇数个的长度输出
一开始想到的是map做,也AC
但是看到题解上说异或,就查了下,看到令人惊奇的做法,记录以下原理
两个相同的数做“异或运算”的结果是0
0与任何数做“异或运算”得其本身

原文链接在此

#include <iostream>
#include <map>

int main()
{
  int num;
  while (std::cin >> num) {
    if (num == 0)
      break;
    std::map<int, int> m;
    int digit;
    for (int i = 0; i < num; ++i) {
      std::cin >> digit;
      if (m.find(digit) == m.end()) m[digit]=1;
      else m[digit]++;
    }
    std::map<int, int>::iterator iter;
    for (iter = m.begin(); iter != m.end(); ++iter) {
      if (iter->second % 2 == 1)
        break;
    }
    std::cout << iter->first << std::endl;
  }
}

#include <stdio.h>
int main()
{
  int num;
  while (scanf("%d", &num) && num != 0) {
    int digit = 0, temp;
    while (num--) {
      scanf("%d", &temp);
      digit ^= temp;
    }
    printf("%d\n", digit);
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值