poj1011(递归)

Sticks
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 151880 Accepted: 36174

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5
#include<iostream>
#include<algorithm>
using namespace std;
int sticks[65];
int used[65];//n根木条是否被切下的标志 
int n,len;//木条数n,木条长度len 
bool dfs(int i,int l,int t)//判断长度len的木棒能否切下n根木条。
//参数:待切割的木条序号i,当前木棒的剩余长度l,剩余木棒的长度和t 
{
	if(l==0)//从一根长度为len的木榜上完整切下木条 
	{
		t-=len;//计算剩余木棒的长度和 
		if(t==0) return true;
		for(i=0;used[i];++i);//按长度递减顺序枚举第一根未使用的木条 
		used[i]=1;//切下木条i 
		if(dfs(i+1,len-sticks[i],t)) return true;//若能切下剩余的木条,则成功返回 
		used[i]=0;t+=len;
	}
	else{
		for(int j=i;j<n;++j)//按长度递减顺序枚举木条i至n-1 
		{
			if(j>0&&(sticks[j]==sticks[j-1]&&!used[j-1])) continue;
//若木条j-1的长度和木条j的长度相同且没有被使用,则枚举木条j+1			
			if(!used[j]&&l>=sticks[j])//若木条j未切下且l不小于其长度,则切下木条j 
			{
				l-=sticks[j];used[j]=1;
				if(dfs(j,l,t)) return true;//若能切下剩余木条则成功返回 
				l+=sticks[j];used[j]=0;//恢复递归前的参数 
				if(sticks[j]==l) break;//若当前木棒切出木条j后,余下木棒无法完成切割木条的任务,则失败返回 
			}
		}
	}
	return false;
}
bool cmp(const int a,const int b)
{
	return a>b;
}
int main()
{
	while(cin>>n&&n)
	{
		int sum=0;
		for(int i=0;i<n;i++)
		{
			cin>>sticks[i];sum+=sticks[i];
			used[i]=0;//标志所有木条未被切下 
		}
		sort(sticks,sticks+n,cmp);//按长度递减排序 
		bool flag=false;//标志木棒为一根 
		for(len=sticks[0];len<=sum/2;++len)//在[sticks[0],sum/2]区间内按递增顺序枚举sum的因子len 
		{
			if(sum%len==0)//sum一定能被len整除 
			{
				if(dfs(0,len,sum))
				{
					flag=true;//若len成立则标志木棒非一根 
					cout<<len<<endl;
					break;
				}
			}
		}
		if(!flag) cout<<sum<<endl;//输出长度为sum的一根木棒切出n根木条 
	}
	return 0;
 }

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值