dijkstra(poj1502 MPI Maelstrom )

MPI Maelstrom
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11305 Accepted: 6966

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system. 
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.'' 

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked. 

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.'' 

``Is there anything you can do to fix that?'' 

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.'' 

``Ah, so you can do the broadcast as a binary tree!'' 

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100. 

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j. 

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied. 

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

给了一半的图的邻接表,x就代表两点之间没有通路。题目求的是从第一个processor传播到整个网络的最短时间。

求一点到其他所有点的最短路径中的最长路径。

#include<iostream>
#include<cstring>
#include<algorithm>  
using namespace std;
const int MAX=0xfffffff;
int edge[105][105];
int dis[105];
bool vis[105];
int num;
void init()
{
	memset(vis,false,sizeof(vis));
	for(int i=1;i<=num;i++)
	{
		for(int j=1;j<=num;j++)
		{
			if(j==i) edge[i][j]=0;
			else edge[i][j]=-1;
		}
		dis[i]=MAX;
	}
	return ;
}
void dijkstra(int n)
{
	int i,j;
	int position=n;
	vis[position]=true;
	dis[position]=0;
	for(i=1;i<=num-1;i++)//一共要添加进num-1个点 
	{
		for(j=1;j<=num;j++)
		{
			if(!vis[j]&&edge[position][j]!=-1&&dis[position]+edge[position][j]<dis[j])
			{
				dis[j]=dis[position]+edge[position][j];
			}
		}
		int min_value=MAX,min_pos;
		for(j=1;j<=num;j++)//比较出最小的那一个作为新添入的店点 
		{
			if(!vis[j]&&dis[j]<min_value)
			{
				min_value=dis[j];
				min_pos=j;
			}
		}
		vis[min_pos]=true;
		position=min_pos;
	}
	return ;
}
int main()
{
	char temp[30];
	cin>>num;
	init();
	for(int i=2;i<=num;i++)
	{
		for(int j=1;j<i;j++)
		{
			cin>>temp;
			if(strcmp(temp,"x")) edge[j][i]=edge[i][j]=atoi(temp);
		}
	}
	dijkstra(1);
	int max_value=-1;
	for(int i=1;i<=num;i++)
	{
		if(dis[i]>max_value) max_value=dis[i];
	}
	cout<<max_value<<endl;
	return 0;
 } 
atoi() 函数用来将字符串转换成整数(int),其原型为:
int atoi (const char * str);

【函数说明】atoi() 函数会扫描参数 str 字符串,跳过前面的空白字符(例如空格,tab缩进等,可以通过 isspace() 函数来检测),直到遇上数字或正负符号才开始做转换,而再遇到非数字或字符串结束时('\0')才结束转换,并将结果返回。

【返回值】返回转换后的整型数;如果 str 不能转换成 int 或者 str 为空字符串,那么将返回 0。

http://www.cnblogs.com/bluestorm/p/3168719.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值