贪心算法

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16565    Accepted Submission(s): 9651


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
 
 
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
 
 
0 3

5

此题大致思路,既然要计算最少扣多少分,就要在最后时间之前把扣分最多的作业先安排了。如果扣分一样多的话,那必然要把时间比较紧的先安排了。所以先按扣分的高低,由高向低排序,如果两门课扣分相同就按他们的结束时间由低向高排序!

每次都把作业安排在离它的截止期限最近的一天,并把此天标记为已用,若不能安排,则扣分。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
struct homework
{
	int dea;
	int sco;
}hom[1005];
bool cmp(homework a,homework b)
{
	if(a.sco==b.sco) return a.dea<b.dea;
	return a.sco>b.sco;
}
int main()
{
	int t;cin>>t;
	while(t--)
	{
		int n,i,j;cin>>n;
		int num[1006];memset(num,0,sizeof(num));
		for(int i=0;i<n;i++) scanf("%d",&hom[i].dea);
		for(int i=0;i<n;i++) scanf("%d",&hom[i].sco);
		sort(hom,hom+n,cmp);
		int ans=0;
		for(i=0;i<n;i++)
		{
			for(j=hom[i].dea;j>0;j--)//从最后的期限开始考虑前几天有没有被安排 
			{
			if(num[j]==0)
			{
				num[j]=1;
				break;
			}
		    }
		    if(j==0) //如果一直到结束都没有空余时间,只能扣分 
			ans+=hom[i].sco;
		}
		cout<<ans<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值