bfs迷宫(poj2251dungeon master)

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 44624 Accepted: 16801

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题意:你被困在一个3D地牢里,想要逃出地牢,有六个逃跑方向:上、下、左、右、前和后,S为你的起始位置,E为出口,"."为路,"#"为墙,若你能逃出,求出你能逃出的最短时间。

题解:和二维思想的基本一样,不过是要建立一个三维数组,求法和二维的一样。-----BFS-----

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
using namespace std;
int a,b,c,sx,sy,sz,ex,ey,ez;
char map[35][35][35];
bool vis[35][35][35];
struct node
{
	int x,y,z;
	int step;
};
int dx[6]={1,-1,0,0,0,0};
int dy[6]={0,0,1,-1,0,0};
int dz[6]={0,0,0,0,1,-1};
bool ok(int x,int y,int z)
{
	if(x>0&&x<=a&&y>0&&y<=b&&z>0&&z<=c&&!vis[x][y][z]&&map[x][y][z]!='#')
	return true;
	return false;
}
int bfs(int x,int y,int z)
{
	queue<node> q;
	node start;
	start.x=x;start.y=y;start.z=z;
	start.step=0;
	q.push(start);
	while(!q.empty())
	{
		node cur=q.front();
	//	cout<<cur.x<<" "<<cur.y<<" "<<cur.z<<endl;
		q.pop();
		if(cur.x==ex&&cur.y==ey&&cur.z==ez) return cur.step;
		node next;
		for(int i=0;i<6;i++)
		{
			next.x=cur.x+dx[i];
			next.y=cur.y+dy[i];
			next.z=cur.z+dz[i];
			if(ok(next.x,next.y,next.z))
			{
				next.step=cur.step+1;
				vis[next.x][next.y][next.z]=true;
				q.push(next);
			}
		}
	}
	return 0;
}
int main()
{
	while(cin>>a>>b>>c&&(a||b||c))
	{
		memset(map,0,sizeof(map));
		memset(vis,false,sizeof(vis));
		for(int i=1;i<=a;i++)
		{
			for(int j=1;j<=b;j++)
			{
			    for(int k=1;k<=c;k++)
			    {
			    	cin>>map[i][j][k];
			    	if(map[i][j][k]=='S')
			    	{
			    		sx=i;sy=j;sz=k;
					}
					if(map[i][j][k]=='E')
					{
						ex=i;ey=j;ez=k;
					}
				}
				getchar();
			}
			getchar();
		}
	//	ex=3;ey=4;ez=5;
	//    cout<<sx<<" "<<sy<<" "<<sz<<endl;
	//	cout<<ex<<" "<<ey<<" "<<ez<<endl;
		vis[sx][sy][sz]=true;
		int ans;
		ans=bfs(sx,sy,sz);
		if(!ans) cout<<"Trapped!"<<endl;
		else cout<<"Escaped in "<<ans<<" minute(s)."<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值