1030. 完美数列(25)
时间限制 300 ms
内存限制 65536 kB
代码长度限制 8000 B
判题程序 Standard
作者 CAO, Peng
给定一个正整数数列,和正整数p,设这个数列中的最大值是M,最小值是m,如果M <= m * p,则称这个数列是完美数列。
现在给定参数p和一些正整数,请你从中选择尽可能多的数构成一个完美数列。
输入格式:
输入第一行给出两个正整数N和p,其中N(<= 105)是输入的正整数的个数,p(<= 109)是给定的参数。第二行给出N个正整数,每个数不超过109。
输出格式:
在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。
输入样例:
10 8
2 3 20 4 5 1 6 7 8 9
输出样例:
8
原题地址:https://www.patest.cn/contests/pat-b-practise/1030
这道题要求最大值, 于是想到了二分搜索算法:
设条件C(x):可以选择x个数使得 M*m <= P
根据这个条件进行搜索,不断减小范围就可以找到答案
这个算法的关键是怎么高效的判断C(x):
我的想法是预先排序一下, 然后循环判选择断连续的x个数是否满足完美数列的条件
首先我们讨论以a[i]为最小值(左边界)选择x个数满足完美数列的条件:
存在一个t >= i+x-1, 使a[t] <= a[i]*P
设t0 = i*x-1
则a[t0] <= a[t1] <= … <= a[N-1]
如果a[t0]<= a[i]*P
则肯定存在t>=t0, a[t] <= a[i]*P成立
因此只要判断t0是否满足条件就可以了
这样i循环一次复杂度就是O(N)了
C(x)的复杂度就是O(N),二分是O(logN),总的就是O(NlogN), 足够了
这样写出来之后,发现最后一个测试无法通过,便想了想应该是边界问题,于是加上了判断搜索结果的正确性,提交之后还是一样,然后仔细看看题目,感觉可能是判断M<=m*P时左边数据溢出了, 于是把数据改成了long , 果然AC了
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <cctype>
using namespace std;
int N, P;
long a[100000];
bool C(int x)
{
for(int i = 0; i + x - 1 < N; i ++){
if(a[i + x - 1] <= a[i] * P)
return true;
}
return false;
}
void solve()
{
sort(a, a + N);
int lb = 1, ub = N + 1;
while(ub - lb > 1){
int mid = (lb + ub) / 2;
if(C(mid))
lb = mid;
else
ub = mid;
}
if(lb <= N)
cout << lb << endl;
else
cout << "0" << endl;
}
int main()
{
cin >> N >> P;
for(int i = 0; i < N; i ++){
cin >> a[i];
}
solve();
return 0;
}
这里再加上根据网上别人的思路写的代码:
复杂度是O(N^2),优化了下,没有超时**
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
int N, ans = 1;
long P;
cin >> N >> P;
long a[N];
for(int i = 0; i < N; i ++)
cin >> a[i];
sort(a, a + N);
for(int i = 0; i < N; i ++)
for(int x = ans; x + i - 1 < N; x ++){
if(a[i] * P >= a[x + i - 1])
ans = x;
else
break;
}
cout << ans;
}