PAT Basic1054

 

1054 求平均值 (20)(20 分)

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legalnumber”,其中X是输入。最后在一行中输出结果:“The average of K numbers isY”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“Theaverage of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

 

这道题很奇怪,我考虑了多种非法情况,反而通不过。总结这道题仅需考虑:

 

1.字符串中包含除了- . 和 0-9以外的违法字符
2.不包含违法字符
  不包含小数点,但转化的整数<-1000 或者>1000
  包含一个小数点,但小数点后的字符数大于2
  包含2个以上的小数点,此时违法

还有只有一个合法数据的时候,输出的是The average of %d number is %.2f,不是numbers(但是测试点并没有这一点)

我多考虑了0987,-0987 ,-0.23,以及45.这些非法数据,反而没有通过,白白浪费时间。。。。。。。。

#include<iostream>

#include<string.h>
#include<string>
#include<cstdlib>
using namespace std;
double xx[101];
int g = 0;
int flag = 0;
int main()
{
    char s[1010];
    int N;
    int ct3 = -2;
    int ct1 = 0, ct2 = 0;
    cin >> N;
    for (int i = 0; i < N; i++)
    {
        ct1 = 0; ct2 = 0; ct3 = -1;
        flag = 0;
        cin >> s;
        for (int j = 0; j < strlen(s); j++)
        {
            if (isdigit(s[j]) || s[j] == '-' || s[j] == '.')
            {
                if (ct3>=0)ct3++;
                if (s[j] == '-')ct1++; if (s[j] == '.'){ ct2++; ct3 = 0; }
                //对0的处理,0987,0.34,-0.78
                /*if (s[0] == 48){   //正数第一个数字不为0即可
                    if (s[1] != '.'){
                        printf("ERROR: %s is not a legal number\n", s); flag = 1;
                        break;
                    }
                }
                if (s[0] == '-'){
                    if (s[1] == '.'){
                        printf("ERROR: %s is not a legal number\n", s); flag = 1;
                        break;
                    }
                    if (s[1] == '0'&&s[2] != '.'){
                        printf("ERROR: %s is not a legal number\n", s); flag = 1;
                        break;
                    }
                }
                if (s[0] == '.'){
                    printf("ERROR: %s is not a legal number\n", s); flag = 1;
                    break;
                }*/
                //转化为double型,看范围和精度符合要求?

            }
            else
            {
                printf("ERROR: %s is not a legal number\n", s); flag = 1;
                break;
            }
        }
        if (flag == 0){
            if (ct1 > 1 || ct2 > 1) { printf("ERROR: %s is not a legal number\n", s); }
            else {
                //cout << " " << ct3 << endl;
                double pp = atof(s);
                if (pp<-1000 || pp>1000){ printf("ERROR: %s is not a legal number\n", s); }
                else if (ct3>2)printf("ERROR: %s is not a legal number\n", s);
                else  xx[g++] = pp;

            }
        }
    }
    if (g == 0)cout << "The average of 0 numbers is Undefined";
    else {
        double sum = 0;
        for (int i = 0; i < g; i++)
            sum += xx[i];
        if (g != 1)    printf("The average of %d numbers is %.2f", g, sum / g);
        if (g == 1)printf("The average of %d number is %.2f", g, sum / g);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值