HDU Problem 2199 Can you solve this equation? 【二分】

 

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16602    Accepted Submission(s): 7371


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 

题中说解在0~100之间,所以当输入的值小于x=0时的值大于x=100时候的值是不存在的,其他情况都有解,所以,对于其他情况,直接进行二分。

#include <cstdio>
#include <cmath>
using namespace std;

const double sp = 1e-5;
double ans(double x) {
    return 8*pow(x, 4.0) + 7*pow(x, 3.0) + 2*pow(x, 2.0) + 3*x + 6;
}

double lower_bound(double x) {
    double l = 0, r = 100;
    double mid = (l + r)/2;
    while (abs(ans(mid) - x) > sp) {
        mid = (l + r)/2;
        if (ans(mid) > x) {
            r = mid;
        }
        else {
            l = mid;
        }
    }
    return mid;
}
int main() {
    int t;
    double n;
    scanf("%d", &t);
    while (t--) {
        scanf("%lf", &n);
        if (n < 6 || n > ans(100.0))
            printf("No solution!\n");
        else printf("%.4lf\n", lower_bound(n));
    }
    return 0;
}



 

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值