Can you solve this equation? HDU - 2199 (二分)

Can you solve this equation?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 26314 Accepted Submission(s): 11274
Problem Description
Now,given the equation 8x^4 + 7x^3 + 2x^2 + 3x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!
Author
Redow

题目的大意是 给定一个关于x的函数f(x),然后再给定一个Y,让你在 0<=x <=100的范围内找出一个x使得函数f(x)等于Y
很容易看出来这个函数在0,100间是单调递增的(那么我们就采用二分法)

对x的区间不断的进行二分,直到fab(f(x)-Y)的值逼近一个EPS(一个很小很小的数字)就可以了

AC代码如下:

#include <iostream>
#include <cmath>
#include <iomanip>
using namespace std;
double Y;
double Function(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;  //用来计算函数值
}
const double EPS=1e-5; //控制精度
double twofen(double low,double high) //二分
{
    double mid=(low+high)/2; 
    while(fabs(Function(mid)-Y)>EPS)
    {
        if(Function(mid)>Y) //因为是单调递增的函数,所以如果f(mid)的值比Y大,说明mid在我们想找的x的右边
            high=mid;
        else low=mid; //反之
        mid=(low+high)/2;
    }
    return mid;
}
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>Y;
        cout<<fixed<<setprecision(4);  //控制数据精度为小数点4位
        if(Function(0)>Y || Function(100)<Y) //因为是单调递增的函数,所以如果 当 x=0大于Y的时候,和X=100 小于Y的时候不可能找到解
            cout<<"No solution!"<<endl;
        else cout<<twofen(0,100)<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值