HDU Problem 5615 Jam's math problem 【十字交叉,暴力】

Jam's math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1353    Accepted Submission(s): 610


Problem Description
Jam has a math problem. He just learned factorization.
He is trying to factorize  ax2+bx+c  into the form of  pqx2+(qk+mp)x+km=(px+k)(qx+m) .
He could only solve the problem in which p,q,m,k are positive numbers.
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 

Input
The first line is a number  T , means there are  T(1T100)  cases 

Each case has one line,the line has  3  numbers  a,b,c(1a,b,c100000000)
 

Output
You should output the "YES" or "NO".
 

Sample Input
  
  
2 1 6 5 1 6 4
 

Sample Output
  
  
YES NO
Hint
The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5867  5866  5865  5864  5863 
 

#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
#define space " "
using namespace std;
//typedef long long LL;
typedef __int64 Int;
typedef pair<int,int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double Pi = acos(-1);
const int MOD = 1e9+5;
const int MAXN = 1e5 + 10;
Int a, b, c;
int main() {
    int T;
    cin >> T;
    while (T--) {
        cin >> a >> b >> c;
        bool flag = false;
        if (b*b < 4*a*c) {
            cout << "NO" << endl;
        }
        else {
            Int sa = sqrt(a), sc = sqrt(c);
            for (int i = 1; i <= sa; i++) {
                if (a%i) continue;
                for (int j = 1; j <= sc; j++) {
                    if (c%j == 0) {
                        Int x = a/i, y = c/j;
                        if ((i*j + x*y) == b || (i*y + j*x) == b) {
                            flag = true; break;
                        }
                    }
                }
                if (flag) break;
            }
            if (flag)   cout << "YES" <<endl;
            else    cout << "NO" << endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值