Jam's math problem(HDU5615)

Jam's math problem

Problem Description

Jam has a math problem. He just learned factorization.
He is trying to factorize ax2+bx+c into the form of pqx2+(qk+mp)x+km=(px+k)(qx+m).
He could only solve the problem in which p,q,m,k are positive numbers.
Please help him determine whether the expression could be factorized with p,q,m,k being postive.

 

 

Input

The first line is a number T, means there are T(1≤T≤100) cases

Each case has one line,the line has 3 numbers a,b,c(1≤a,b,c≤100000000)

 

 

Output

You should output the "YES" or "NO".

 

 

Sample Input

 

2 1 6 5 1 6 4

 

 

Sample Output

 

YES NO

题意:方程的因式分解,十字相乘,例如x^2+6*x+5=(x+1)(x+5),这样就可以分解,可以通过Δ=b²-4ac进行判定,首先Δ得大于0,然后Δ=为完全平方数就可以分解,此处只需记住。。。。。。。。。。。。。。。。。
代码:
#include<stdio.h>
#include<math.h>
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long int a,b,c,d,e;
        scanf("%lld%lld%lld",&a,&b,&c);
        d=b*b-4*a*c;  //Δ小于0直接输出NO,因为这样就没解
        if(d<0)printf("NO\n");
        else
        {
            e=sqrt(d);    
            if(e*e==d)printf("YES\n");     //为完全平方数就输出YES
            else printf("NO\n");
        }
    }
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值