HDU:5615 Jam's math problem(暴力,数学)

4 篇文章 0 订阅
4 篇文章 0 订阅

Jam's math problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1313    Accepted Submission(s): 583


Problem Description
Jam has a math problem. He just learned factorization.
He is trying to factorize  ax2+bx+c  into the form of  pqx2+(qk+mp)x+km=(px+k)(qx+m) .
He could only solve the problem in which p,q,m,k are positive numbers.
Please help him determine whether the expression could be factorized with p,q,m,k being postive.
 

Input
The first line is a number  T , means there are  T(1T100)  cases 

Each case has one line,the line has  3  numbers  a,b,c(1a,b,c100000000)
 

Output
You should output the "YES" or "NO".
 

Sample Input
  
  
2 1 6 5 1 6 4
 

Sample Output
  
  
YES NO
Hint
The first case turn $x^2+6*x+5$ into $(x+1)(x+5)$
 

Source
 

Recommend
hujie

题目大意:给一个a、b、c,其中a、b、c是a*x^2+b*x+c中的abc,问所给的abc能否使用十字相乘法。
解题思路:a=pq;b=qk+mp;c=km。暴力枚举来拆分a、c,拆开后看是否满足b==qk+mp(即pk+qm==b||pm+qk==b)。
代码如下:
#include <cstdio>
#define LL long long
#define sc(x) scanf("%lld",&x)
int main()
{
	LL t;
	sc(t);
	LL a,b,c;
	while(t--)
	{
		sc(a);
		sc(b);
		sc(c); 
		LL flag=0;
		for(LL i=1;i*i<=a;i++)//节省时间,因为sqrt以后的都重复了 
		{
			if(a%i!=0)
			continue;
			for(LL j=1;j*j<=c;j++)//节省时间,因为sqrt以后的都重复了 
			{
				if(c%j!=0)
				continue;
				if(((i*j+(a/i)*(c/j))==b)||(i*(c/j)+j*(a/i)==b))
				{
					flag=1;
					break;
				}
			}
			if(flag==1)
			break; 
		}
		if(flag==0)
		{
			printf("NO\n");
		}
		else
		{
			printf("YES\n");
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值