POJ2002---Squares(找正方形的个数)

4 篇文章 0 订阅
2 篇文章 0 订阅
Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 17569 Accepted: 6690

题意:给出一些整数点求尤其组成的正方形的个数;

枚举哈希;


Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source

Rocky Mountain 2004
#include <iostream>
#include<cstdio>
#include<queue>
#include<stack>
#include<cstring>
#include<algorithm>
#include<cmath>
#define INF0x3f3f3f3f
using namespace std;
const int N=997;
struct point
{
    int x,y;
}points[N+10];
struct node
{
    int x,y;
    int next;
}T[N+10];
int head[N+10];
int top;
void build(point p)
{
int sum=(p.x*p.x+p.y*p.y)%N;
   T[top].x=p.x;
   T[top].y=p.y;
   T[top].next=head[sum];
   head[sum]=top++;
}
bool Query(point p)
{
    int sum=(p.x*p.x+p.y*p.y)%N;
    int q=head[sum];
    while(q!=-1)
    {
        if(T[q].x==p.x&&T[q].y==p.y)
            return 1;
        q=T[q].next;
    }
    return 0;
}
int main()
{
     int n,x,y;
     while(scanf("%d",&n),n)
     {
         top=0;
         memset(head,-1,sizeof(head));
         for(int i=0;i<n;i++)
         {
             scanf("%d%d",&x,&y);
             points[i].x=x<<1;
             points[i].y=y<<1;
             build(points[i]);
         }
         int g,h,u,v;
         point a,b;
         int ans=0;
         for(int i=0;i<n;i++)
         {
             for(int j=i+1;j<n;j++)
                {
                    g=(points[i].x+points[j].x);
                    h=(points[i].y+points[j].y);
                    u=(points[j].x-points[i].x);
                    v=(points[i].y-points[j].y);
                    a.x=(g-v)/2;
                    a.y=(h-u)/2;
                    b.x=(v+g)/2;
                    b.y=(h+u)/2;
                    if(Query(a)&&Query(b))
                        ans++;
                }
         }
         printf("%d\n",ans/2);
     }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值