hdu5430(BestCoder Round #54 (div.2)1004题)

Reflect

Accepts: 72
Submissions: 302
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/65536 K (Java/Others)
Problem Description
We send a light from one point on a mirror material circle,it reflects N times and return the original point firstly.Your task is calcuate the number of schemes. ![](../../data/images/C628-1004-1.jpg)
Input
First line contains a single integer T(T10) which denotes the number of test cases. For each test case, there is an positive integer N(N106) .
Output
For each case, output the answer.
Sample Input
1
4
Sample Output
4
 
   
分析:这题是由UVa12493题改编的,但几乎是一模一样的。因为之前碰到过,某学长有详细的解析报告。我就不瞎扯了。
附上学长博客:寻找&星空の孩子
 
   
#include<stdio.h>
#define LL long long
//UVA用
LL fun(LL m)
{
    LL res=m;
    for(LL i=2;i*i<=m;i++)
    {
        if(m%i==0)
        {
            res=(res*(i-1))/i;
 //           printf("i=%I64d,res=%I64d\n",i,res);
            while(m%i==0)
            {
                m/=i;
            }
        }
    }
    if(m>1) res=(res*(m-1))/m;
    return res;
}
int main()
{
    LL n;
    int T;
    scanf ("%d",&T);
    while(T--)
    {
        scanf("%lld",&n);
        printf("%lld\n",fun(n+1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值