B - Frequent values

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4

3

题意:一组升序的数字,问你某一区间同一数字的最大连续和

解法:RMQ,但同时得注意,每次区间求值的时候得注意更新区间右端点的值,详情看代码

<span style="font-size:18px;">#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<math.h>
using namespace std;
int a[100010],dp[100010][20],b[100010];
int main()
{
    int n,m,i,j,x,y;
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        int tmp;
        for(int i=n-1;i>=0;i--)
        {
            if(i==n-1) tmp=1;
            else
            {
                if(a[i]==a[i+1])tmp++;
                else tmp=1;
            }
            b[i]=tmp;//倒着存
        }
        for( i=0;i<n;i++)
            dp[i][0]=b[i];
        for( j=1;(1<<j)<=n;j++)
            for( i=0;i+(1<<j)-1<n;i++)
                dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
        while(m--)
        {
            scanf("%d%d",&x,&y);
            x--;//从0开始的
            y--;
            int ma;
            if(a[x]==a[y])//询问区间内为同一数字
                printf("%d\n",y-x+1);
            else
            {
                int tmp = lower_bound(a,a+n,a[y])-a;//二分求值,不然要超时,求出与右区间端点同一数字最左的位置
                ma=y-tmp+1;
                y=tmp-1;
               int k=(int)(log(y-x+1.0)/log(2.0));
                printf("%d\n",max(ma,max(dp[x][k],dp[y-(1<<k)+1][k])));//输出两者最大值
            }
        }
    }
    return 0;
}</span>


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值