HDOJ~~A + B Problem II



A + B Problem II  


 Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

 Problem Description
 
 
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

  Input
 
 The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 
  
  Output
 
  For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 
  
  Sample Input
 2
1 2
112233445566778899 998877665544332211

  
  Sample Output
 
 Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include<stdio.h>
#include<string.h>
#define MAX 1001
int main()
{
 int n;
 char num1[MAX],num2[MAX],num3[MAX];
 //num3用来保存结果
 scanf("%d",&n);
 for(int t=0;t<n;t++)
 {
  if(t)
  printf("\n");
  scanf("%s %s",num1,num2);
  //获取两个数字的位数
  int len1=strlen(num1);
  int len2=strlen(num2);
  int len3=0;
  memset(num3,'0',sizeof(num3));
  //按位相加,先不管进位
  for(int i=len1-1,j=len2-1;i>=0&&j>=0;i--,j--)
  {
   num3[len3++]=num1[i]+num2[j]-'0';
   //如果有一个数组先为空,则把另一个数组里剩下的数字放入num3[]中
   if(i==0)
   while(j--) num3[len3++]=num2[j];
   else if(j==0)
   while(i--) num3[len3++]=num1[i];  
  } //进位处理
  for(int i=0;i<len3;i++)
  {
   if(num3[i]>'9')
   {
    num3[i+1]+=(num3[i]-'0')/10;
   }
  } //格式输出
  for(int i=MAX-1;i>=0;i--)
  {
   if(num3[i]!='0')
   {
    printf("Case %d:\n",t+1);
    printf("%s + %s =",num1,num2);
    while(i>=0) printf("%c",num3[i--]);
    printf("\n");
   }
  } 
 }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值