【简单动态规划】How to Type

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string. 
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.


Sample Input
 
 
3PiratesHDUacmHDUACM

 

Sample Output
 
 
888
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

题意:

很有意思的题目,给你一串字符串然后让你模拟在键盘上进行操作如何才能用敲键盘最少的次数来把这一串字符串打出来,要求末尾的时候处于小写输出状态。求最小键盘敲击次数。

分析:

切换大小写有两种方式,一种是shift切换,另一种是captureLock切换。用captureLock切换后会有大写和小写两种状态。所以可以根据目前的大写和小写状态写出状态转移矩阵。代码如下。

代码:

import java.util.Scanner;

public class Main{
    static Scanner input = new Scanner(System.in);
    static boolean isuppercase(char get){
        return !(get>='a'&& get<='z');
    }
    static int[][] dp;
    public static void main(String[] args){
        int count = input.nextInt();
        for(int i=0;i<=count-1;i++){
            dp = new int[2][101];//dp[0][x]大写Lock开启 。  dp[1][x]大写Lock关闭
            String str = input.next();
            for(int j=0;j<=str.length()-1;j++){
                if(j==0){
                    if(isuppercase(str.charAt(0))){
                        dp[0][1] = 2;
                        dp[1][1] = 2;
                    }else{
                        dp[0][1] = 2;
                        dp[1][1] = 1;
                    }
                }else{
                    if(isuppercase(str.charAt(j))){
                        //输入大写字母
                        dp[0][j+1] = Math.min(dp[1][j]+2, dp[0][j]+1);
                        dp[1][j+1] = Math.min(dp[1][j]+2, dp[0][j]+2);
                    }else{
                        //输入小写字母
                        dp[0][j+1] = Math.min(dp[0][j]+2, dp[1][j]+2);
                        dp[1][j+1] = Math.min(dp[0][j]+2, dp[1][j]+1);
                    }
                }
            }
            System.out.println(Math.min(dp[0][str.length()]+1, dp[1][str.length()]));
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值