HDU2577——How to Type 动态规划

题目如下:

Description

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input

The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output

For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input

    
    
3 Pirates HDUacm HDUACM
 

Sample Output

    
    
8 8 8

Hint

 The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8 
 


题目大意:打一串字母,有两种方式更换大小写,按住shift,这样可以使下一个字母的大小写改变(只能改变下一个)。或者打开或关闭大写锁定。问最少按多少次。

分析:显然,打当前字母需要按几次按键取决于大写锁定是否打开。也就是说,我们需要两个状态转移方程。用两个dp数组分别记录大写锁定打开和关闭时最少需要的按键数。注意打完之后大写锁定要是关着的。具体的可以看代码注释。  破题点在于想到用两个dp数组。

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <cmath>
#include <queue>
#include <ctype.h>
using namespace std;
#define INF 1000
#define MAXN 110
char a[MAXN];
int on[MAXN],off[MAXN];//on代表当前大写锁定打开,off代表当前大写锁定关闭
int main()
{
    int t;
    cin>>t;
    getchar();
    while(t--)
    {
        scanf("%s",a+1);
        int n=strlen(a+1);
        on[0]=1;//要打开大写锁定,所以初始值为1
        off[0]=0;
        for(int i=1;i<=n;i++)
        {
            if(isupper(a[i]))//如果当前所输为大写字母
            {
                on[i]=min(on[i-1]+1,off[i-1]+2);//如果是大写锁定打开,则直接+1,如果大写锁定关闭,则得先打开大写锁定,再输入字母,所以+2.
                off[i]=min(on[i-1]+2,off[i-1]+2);//同理
            }
            else
            {
                on[i]=min(on[i-1]+2,off[i-1]+2);//同理
                off[i]=min(on[i-1]+2,off[i-1]+1);//同理
            }
        }
        printf("%d\n",min(on[n]+1,off[n]));
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值