hdu 2196 树形dp

25 篇文章 0 订阅

http://acm.hdu.edu.cn/showproblem.php?pid=2196

Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
/**
hdu 2196  树形dp(kuangbin)
题目大意:求树中每个点到所有叶子节点的距离的最大值是多少。
解题思路:由于对于一个节点来说,可能得到的距离最大的值的路径来自他的子树,或者从他的父节点过来,所以用两次DFS。
           第一次DFS求出所有节点在他的子树范围内到叶子节点距离的最大值和第二大的值,第二次DFS更新从父节点过来的情况就可以了。
           因为如果只存最大值的话,判断一个点的从父节点过来的最大值,那么如果他的父节点存的最大值正好是从该点过来的,那么就
           失去了从父节点过来的状态,所以要记录最大的两个值。
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <algorithm>
using namespace std;
const int maxn=10005;
struct note
{
    int v,next,w;
} edge[maxn*2];
int head[maxn],ip;
int n,maxx[maxn],smaxx[maxn],id[maxn],sid[maxn];

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}

void addedge(int u,int v,int w)
{
    edge[ip].v=v,edge[ip].w=w,edge[ip].next=head[u],head[u]=ip++;
}

void dfs1(int u,int pre)
{
    maxx[u]=0;
    smaxx[u]=0;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        int w=edge[i].w;
        if(v==pre)continue;
        dfs1(v,u);
        if(smaxx[u]<maxx[v]+w)
        {
            smaxx[u]=maxx[v]+w;
            sid[u]=v;
            if(smaxx[u]>maxx[u])
            {
                swap(smaxx[u],maxx[u]);
                swap(id[u],sid[u]);
            }
        }
    }
}

void dfs2(int u,int pre)
{
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        int w=edge[i].w;
        if(v==pre)continue;
        if(v==id[u])
        {
            if(w+smaxx[u]>smaxx[v])
            {
                smaxx[v]=smaxx[u]+w;
                sid[v]=u;
                if(smaxx[v]>maxx[v])
                {
                    swap(maxx[v],smaxx[v]);
                    swap(id[v],sid[v]);
                }
            }
        }
        else
        {
            if(w+maxx[u]>smaxx[v])
            {
                smaxx[v]=maxx[u]+w;
                sid[v]=u;
                if(smaxx[v]>maxx[v])
                {
                    swap(maxx[v],smaxx[v]);
                    swap(id[v],sid[v]);
                }
            }
        }
        dfs2(v,u);
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        init();
        for(int i=2; i<=n; i++)
        {
            int v,w;
            scanf("%d%d",&v,&w);
            addedge(i,v,w);
            addedge(v,i,w);
        }
        dfs1(1,-1);
        dfs2(1,-1);
        for(int i=1; i<=n; i++)
            printf("%d\n",maxx[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值