HDU - 2196 Computer (树形dp详解)

A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
InputInput file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.OutputFor each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).Sample Input
5
1 1
2 1
3 1
1 1
Sample Output
3
2
3
4
4

题意 :求树的每个点到任意点距离的最大值

解  画个图模拟一下

dp[i][0].en 是子树中链的最大值  

dp[i][1].en是子树中链的次大值

dp[i][2].en是经过父亲节点的链的最大值

after 是当前链的起点


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#include<vector>
#include<map>
#define nn 10001
#define mm 500001
#define inff 0x3fffffff
using namespace std;
#pragma comment(linker, "/STACK:102400000,102400000")
int vis[nn];
struct node1
{
    int en;//长度
    int after;//对于哪个儿子节点
}dp[nn][3];
int n,num;
int p[nn];
struct node
{
    int en,next,c;//c是距离
}e[nn];
int init()
{
    memset(p,-1,sizeof(p));
    memset(dp,0,sizeof(dp));
    memset(vis,0,sizeof(vis));
    num=0;
}
int add(int st,int en,int c)
{
    e[num].en=en;
    e[num].next=p[st];
    e[num].c=c;
    p[st]=num++;
}
int dfs(int u)
{
  vis[u]=1;
  for(int i=p[u];i+1;i=e[i].next)
  {
      int v=e[i].en;
      int c=e[i].c;
      if(vis[v]) continue;
      int w=dfs(v)+c;
      if(w>dp[u][0].en)//w大于最大值
      {
        dp[u][1].en=dp[u][0].en;
        dp[u][1].after=dp[u][0].after;
        dp[u][0].en=w;
        dp[u][0].after=v;
      }
      else  if(w>dp[u][1].en)//w大于次大值
      {
        dp[u][1].en=w;
        dp[u][1].after=v;
      }
  }
  return dp[u][0].en;
}
int dfs1(int u)
{
    vis[u]=1;
    for(int i=p[u];i+1;i=e[i].next)
    {
        int v=e[i].en;
        int c=e[i].c;
        if(vis[v]) continue;
        if(dp[u][0].after==v)//如果该节点的父亲节点的最长链正好包括该节点
            dp[v][2].en=c+max(dp[u][1].en,dp[u][2].en);
        else
            dp[v][2].en=c+max(dp[u][0].en,dp[u][2].en);
        dfs1(v);
    }
}
int main()
{
    int a,b,c;
    while(~scanf("%d",&n))
    {
        init();
        dp[1][0].en=dp[1][1].en=dp[1][2].en=0;
        dp[1][0].after=dp[1][1].after=0;
        for(int i=2;i<=n;i++)
        {
        dp[i][0].en=dp[i][1].en=dp[i][2].en=0;
        dp[i][0].after=dp[i][1].after=0;
        scanf("%d%d",&a,&b);
        add(a,i,b);
        }
        dfs(1);
        memset(vis,0,sizeof(vis));
        dfs1(1);
        for(int i=1;i<=n;i++)
            printf("%d\n",max(dp[i][0].en,dp[i][2].en));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值