UVA 536 二叉树的遍历

http://vjudge.net/contest/view.action?cid=50788#problem/B

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

                                    D
                                   / \
                                  /   \
                                 B     E
                                / \     \
                               /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

Output Specification 

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input 

DBACEGF ABCDEFG
BCAD CBAD

Sample Output 

ACBFGED
CDAB
题目大意:给出一个二叉树的前序遍历和中序遍求出它的后序遍历的结果

解题思路: 

               对于前序遍历而言总是先遍历根节点接着是左子树,右子树。对于中序遍历而言就是先遍历左子树,根节点和右子树,因此对遍历顺序为左子树,右子树根节点的后序遍历来说,最后出现的一定是根节点,因此我们只需把根节点和其右左子树的根节点依次入栈,最后将栈里的元素全部退出就可以了

#include <stdio.h>
#include <string.h>
#define M 30
char stack[M];
int top;
void dfs(char *pre,char *mid)
{
    char ps1[M],ps2[M],*qs1,*qs2;
    int index;
    if(strlen(pre))
    {
        stack[top++]=pre[0];
        index=strchr(mid,pre[0])-mid;
        qs1=mid;
        qs2=mid+index+1;
        mid[index]=0;
        strncpy(ps1,pre+1,index);
        ps1[index]=0;
        strcpy(ps2,pre+1+index);
        dfs(ps2,qs2);
        dfs(ps1,qs1);
    }
    return ;
}
int main()
{
    char pre[M],mid[M];
    while(~scanf("%s%s",pre,mid))
    {
         top=0;
         dfs(pre,mid);
         while(top>0)
             printf("%c",stack[--top]);
        puts("");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值