hdu4770 状态压缩+枚举

http://acm.hdu.edu.cn/showproblem.php?pid=4770



Problem Description
Harry: "But Hagrid. How am I going to pay for all of this? I haven't any money." 
Hagrid: "Well there's your money, Harry! Gringotts, the wizard bank! Ain't no safer place. Not one. Except perhaps Hogwarts." 
— Rubeus Hagrid to Harry Potter. 
  Gringotts Wizarding Bank is the only bank of the wizarding world, and is owned and operated by goblins. It was created by a goblin called Gringott. Its main offices are located in the North Side of Diagon Alley in London, England. In addition to storing money and valuables for wizards and witches, one can go there to exchange Muggle money for wizarding money. The currency exchanged by Muggles is later returned to circulation in the Muggle world by goblins. According to Rubeus Hagrid, other than Hogwarts School of Witchcraft and Wizardry, Gringotts is the safest place in the wizarding world.
  The text above is quoted from Harry Potter Wiki. But now Gringotts Wizarding Bank is not safe anymore. The stupid Dudley, Harry Potter's cousin, just robbed the bank. Of course, uncle Vernon, the drill seller, is behind the curtain because he has the most advanced drills in the world. Dudley drove an invisible and soundless drilling machine into the bank, and stole all Harry Potter's wizarding money and Muggle money. Dumbledore couldn't stand with it. He ordered to put some magic lights in the bank rooms to detect Dudley's drilling machine. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:

  Some rooms are indestructible and some rooms are vulnerable. Dudely's machine can only pass the vulnerable rooms. So lights must be put to light up all vulnerable rooms. There are at most fifteen vulnerable rooms in the bank. You can at most put one light in one room. The light of the lights can penetrate the walls. If you put a light in room (x,y), it lights up three rooms: room (x,y), room (x-1,y) and room (x,y+1). Dumbledore has only one special light whose lighting direction can be turned by 0 degree,90 degrees, 180 degrees or 270 degrees. For example, if the special light is put in room (x,y) and its lighting direction is turned by 90 degrees, it will light up room (x,y), room (x,y+1 ) and room (x+1,y). Now please help Dumbledore to figure out at least how many lights he has to use to light up all vulnerable rooms.
  Please pay attention that you can't light up any indestructible rooms, because the goblins there hate light. 

 

Input
  There are several test cases.
  In each test case:
  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 200).
  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, and '.' means a vulnerable room. 
  The input ends with N = 0 and M = 0
 

Output
  For each test case, print the minimum number of lights which Dumbledore needs to put.
  If there are no vulnerable rooms, print 0.
  If Dumbledore has no way to light up all vulnerable rooms, print -1.
 

Sample Input
  
  
2 2 ## ## 2 3 #.. ..# 3 3 ### #.# ### 0 0
 

Sample Output
  
  
0 2 -1
 

Source
/**
hdu4770 状态压缩+枚举
题目大意:给定一个n*m的矩阵有#和.,.可以放电筒,每个电筒可以照上和右加本身三个点,只有一个特殊电筒可以90,180,270度旋转,问最少用多少个电筒
          能把所有的.全覆盖。
题目大意:题目说了总共.的个数不会超过15个,我们要可以把所有的位置枚举一遍。先枚举特殊电筒,枚举其四个旋转方向。然后枚举其他的点。。
         值得一提的是:一点要注意char数组的初始化
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;

vector<pair<int,int> >vec;
int n,m,t,flag,minn,Hash[350*350];
char a[305][305];
int dx[][3][2]= {0,0,-1,0,0,1,
                 0,0,0,1,1,0,
                 0,0,1,0,0,-1,
                 0,0,0,-1,-1,0
                };

bool get(int u,int v)
{
    for(int i=0; i<3; i++)
    {
        int x=vec[u].first+dx[v][i][0];
        int y=vec[u].second+dx[v][i][1];
        if(a[x][y]=='#')return 0;
        if(a[x][y]=='.'&&x>0&&x<=n&&y>0&&y<=m)
        {
            flag|=(1<<Hash[(x-1)*m+y-1]);
        }
    }
    return 1;
}

bool judge(int ans,int flag)
{
    int num=1;
    for(int i=0; i<t; i++)
    {
        if(ans&(1<<i))
        {
            num++;
            for(int j=0; j<3; j++)
            {
                int x=vec[i].first+dx[0][j][0];
                int y=vec[i].second+dx[0][j][1];
                if(a[x][y]=='#')return 0;
                if(a[x][y]=='.'&&x>0&&x<=n&&y>0&&y<=m)
                {
                    flag|=(1<<Hash[(x-1)*m+y-1]);
                }
            }
        }
    }
    if(flag==(1<<t)-1)minn=min(minn,num);
    return 1;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        memset(a,0,sizeof(a));
        for(int i=1; i<=n; i++)
        {
            scanf("%s",a[i]+1);
        }
        vec.clear();
        int kk=0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(a[i][j]=='.')
                {
                    vec.push_back(make_pair(i,j));
                    Hash[(i-1)*m+j-1]=kk++;
                }
            }
        }
        t=vec.size();
        if(t==0)
        {
            puts("0");
            continue;
        }
        minn=0x3f3f3f;
        for(int i=0; i<t; i++)///特殊电筒
        {
            for(int j=0; j<4; j++)///旋转方向
            {
                flag=0;
                if(!get(i,j))continue;
                for(int k=0; k<(1<<t); k++)
                {
                    if(k&(1<<i))continue;
                    judge(k,flag);
                }
            }
        }
        if(minn==0x3f3f3f)minn=-1;
        printf("%d\n",minn);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值