杭电1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39611    Accepted Submission(s): 17453


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

#include<iostream>
#include<cstring>
#define MAX 50
using namespace std;

int n;
int vis[MAX];
int is_prime[MAX];
int a[MAX];

void dfs(int c)
{
	a[0]=1;
	int i;
    if(c==n&&is_prime[a[0]+a[n-1]]!=0)
	{
	    for(i=0;i<n-1;i++)
		cout<<a[i]<<" ";
		cout<<a[n-1]<<endl;	
	}
	else
	{
		for(i=2;i<=n;i++)
		{
			if(vis[i]==0&&is_prime[i+a[c-1]]!=0)
			{
				vis[i]=1;
				a[c]=i;
				dfs(c+1);
				vis[i]=0;
			}
		}
	}
}

int main()
{
	int t,i,j;
	t=1;
	for(i=2;i<50;i++)
	is_prime[i]=i;
	for(i=2;i<9;i++)
	{
		for(j=i+i;j<50;j=j+i)
		{
			is_prime[j]=0;
		}
	}
	while(cin>>n&&n)
	{
		cout<<"Case "<<t++<<":"<<endl;
		if(n%2==0)
		{
	        memset(vis,0,sizeof(vis));
            dfs(1);
            cout<<endl;
		}
		else
		cout<<"No Answer"<<endl;
	}
	return 0;
}



思想是:深搜加回溯

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值