hdu2955 Robberies(另一种01背包)

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21813    Accepted Submission(s): 8061


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6
 

题目分析:这里的01背包是以第二个维度作为衡量量的。即:以总的钱数作为背包容量,概率作为物品价值。因为在这里概率的精度并没有给出,故很难用概率作为背包容量。

《挑战程序设计竞赛》中有一种物体体积过大而不能以体积作为背包容量的题目,这里是差不多的。还有一点就是,抢劫各银行被抓的概率是相互独立的。也就是说是不被抓的概率之和。。。

代码如下:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxx=105;
double dp[maxx*maxx],val[maxx];
int cai[maxx];
int main()
{
    int t;
    cin>>t;
    int n,sum;
    double m;
    while(t--)
    {
        cin>>m>>n;
        sum=0;
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(int i=0; i<n; i++)
        {
            cin>>cai[i]>>val[i];
            val[i]=1-val[i];
            sum+=cai[i];
        }
        for(int i=0; i<n; i++)
        {
            for(int j=sum; j>=cai[i]; j--)
            {
                double pp=dp[j-cai[i]]*val[i];
                dp[j]=max(dp[j],pp);
            }
        }
        for(int i = sum; i <= 0; i++)//在这里顺序会出错,而我并不知道错在哪里。真尴尬。
        {
            if(dp[i]<(1 - m))
            {
               cout<<i<<endl;
                break;
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值