Aggressive cows POJ 2456 (二分,最大化最小值)

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14977 Accepted: 7219

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

题目分析:先对隔间编号从小到大排序,则最大距离不会超过两端的两头牛之间的差值,最小值为0。所以我们可以通过二分枚举最小值来求。假设当前的最小值为x,如果判断出最小差值为x时可以放下C头牛,就先让x变大再判断;如果放不下,说明当前的x太大了,就先让x变小然后再进行判断。直到求出一个最大的x就是最终的答案。

代码如下:

//
// Created by kzl on 17-7-25.
//

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxx = 1e5+500;
int n,c;
int cun[maxx];

bool flag(int num){
    int aa = cun[0];
    int temp = 1;
    for(int i=1;i<n;i++)
    {
        if(cun[i]-aa>=num){
            temp++; aa = cun[i];
        }
if(temp==c)return true;
    }
    return false;
}


int main(){
while (scanf("%d%d",&n,&c)!=EOF)
{
    for(int i=0;i<n;i++)scanf("%d",&cun[i]);
    sort(cun,cun+n);
    int l = 1,r = cun[n-1],mid = 0,ans = r+1;
    while(l<=r){
        mid = ((r-l)>>1)+ l;
        if(flag(mid))l = mid + 1;
        else  r = mid - 1;
    }
    printf("%d\n",l-1);
}
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值