Drying POJ - 3104 (二分)

Drying
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16738 Accepted: 4243

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

题目大意:有n件衣服,每件衣服的含水量为ai单位,每分钟他们能自然脱水1单位,有一个脱水机,每次只能对一件衣服脱水,脱水量为k单位(),问所有衣服全部风干的最小时间是多少?
分析:首先能够想到的是可以二分查找全部风干的最少时间,对于某次二分出的一个值mid:
1、对于一件ai值小于等于mid的衣服,直接晾干即可;
2、对于一件ai值大于mid值的衣服,最少的用时是用机器一段时间,晾干一段时间,设这两段时间分别是x1和x2,那么有mid=x1+x2,ai<=k*x1+x2,解得x1>=(ai-mid)/(k-1) ,所以对(ai-mid)/(k-1)向上取整就是该件衣服的最少用时。

代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
long long n,k,a[100005],l,h,mid,cnt,q,ans;
long long max(long long x,long long y)
{
    if (x<y) return y;
    else return x;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        h=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            h=max(h,a[i]);
        }
        cin>>k;
        l=0;
        else
        {
        while(l<=h)
        {
            cnt=0;
            mid=(l+h)>>1;
            for(int i=0;i<n;i++)
            {
                q=a[i]-mid;//判断mid值与当前ai的关系。
                if (q>0)//如果大于的话,额外算熨斗时间。
                {
                    cnt+=q/(k-1);
                    if(q%(k-1)!=0) cnt++;
                }
            }
            if (cnt<=mid)
            {
                h=mid-1;
            }
            else l=mid+1;
        }
        cout<<h+1<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值