HDU1013

1013
Digital Roots
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 79453 Accepted Submission(s): 24833

Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output
For each integer in the input, output its digital root on a separate line of the output.

Sample Input
24
39
0

Sample Output
6
3

Source
Greater New York 2000

Recommend
We have carefully selected several similar problems for you: 1017 1021 1018 1002 1048


**题目分析:
取每一位的数相加,其和为个位数即为树根,否则再和取每一位数相加直到其为树根。由于得出个位数是mod10,避免出现10和不可能为0就只有(n-1)%9+1。**
这道题自己模拟做,没通过,看大佬的知道了也可以总结数论(还有很多值得注意的地方),但还是没通过,发现是数据量的问题,这道题的输入在我比对后,最大1001,数据串长度小于1001就是错。

#include<stdio.h>
#include<string.h>
int main()
{
    char num[1001];
    int n, len;
    while (scanf("%s", num) && num[0] != '0') {
        n = 0;
        len = strlen(num);
        for (int i = 0; i < len; i++)
            n += num[i] - '0';
        printf("%d\n", (n - 1) % 9 +1) ;
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值